Problème d'affichage lors de l'utilisation de la langue arabe

Messagepar samia » Lun 25 Fév 2008, 13:20

Bonjout tous le monde
J'ai integré le package de la langue arabe dans mon site mais je rencontre des problèmes d'affichage.
Sous IE6 : mon problme est que tout le contenue de mon site décale vers la droite et je ne peut visualiser presque que le menu gauche.
Sous FireFox : Le site ne décale pas mais j'ai les menus Acceuil/contact... décaler vers la droite (il est normalement centré), le contenue du box rechercher aussi décalé vers la droite
Autre que l'affichage, quand je choisie lalngue arabe et puis je clic sur n'importe quel lien la langue retourne en français (j'ai français et arabe comme langies).
Si quelqu'un peut m'aider.
Je pense que c'est problème de css, si vous avez besoins je vous affiche mon code CSS.
Je travail en local.
samia
Membre actif
 
Messages: 72
Inscription: Ven 06 Juil 2007, 09:36

Messagepar oscim » Lun 25 Fév 2008, 14:01

Question sur la langue arabe. elle est codé comment ? tu peut me montrer un fichier ?

Sinon, pourles pbs de décalage, tu ne les as pas en fr ?

logiquement, la langue fonctionne entre autre avec la detection de la langue de ton navigateur. si c'est la francais par default, alors ru retombera en francais.

Par contre une fois identifié, et choix de la langue, tehoriement celle ci doit rester engagé.
Pour un web au normes du W3C, pour un web plus propre !

- Download osCSS Toutes versions
- stable osCSS 2.1.0 (help|info|new dev) Official help|wiki|Tuto for osCSS 2 | doc doxygen
- Utiliser le tracker pour suivre les évolutions et développements
- Inscrivez vos sites sur oscss pour présenter vos réalisations
Avatar de l’utilisateur
oscim
Site Admin
 
Messages: 1643
Inscription: Mar 25 Sep 2007, 11:33

Messagepar samia » Lun 25 Fév 2008, 17:57

Merci oscim, je répend à vos questions :
J'ai télécharger le package depuis ce lien :
http://www.oscommerce.com/community/con ... earch,arab
En français tous est bien afficher, y a pas de décalage.
Oui c'est le français par défaut, mais ya-t-il une possibilité de ne revenir en français que si l'internaute choisie la langue française?
samia
Membre actif
 
Messages: 72
Inscription: Ven 06 Juil 2007, 09:36

Messagepar oscim » Lun 25 Fév 2008, 21:02

En fait la langue par default est choisi. sauf si arabe configuré dans le navi de l'user. Pour tous les autres lang default=fr
Pour un web au normes du W3C, pour un web plus propre !

- Download osCSS Toutes versions
- stable osCSS 2.1.0 (help|info|new dev) Official help|wiki|Tuto for osCSS 2 | doc doxygen
- Utiliser le tracker pour suivre les évolutions et développements
- Inscrivez vos sites sur oscss pour présenter vos réalisations
Avatar de l’utilisateur
oscim
Site Admin
 
Messages: 1643
Inscription: Mar 25 Sep 2007, 11:33

Messagepar samia » Mar 26 Fév 2008, 11:01

Merci
Mais pour l'affichage y-a-til une solution?ou bien que peut etre le problème qui cause se décalage?
Moi je doute l'utilisation des "Float" dans le CSS, j'utilise Float:left; tandisque la langue arabe exige l'ecriture de droite à gauche.Mais en supprimmant les "float", l'affichage en français décale aussi!!!
De l'aide SVP
samia
Membre actif
 
Messages: 72
Inscription: Ven 06 Juil 2007, 09:36

Messagepar j4k » Mar 26 Fév 2008, 11:36

essai de voir si tu ne peut pas iltrer les classes css par la langues. je sais qu'il y a certaines classe pour les langues.

si elles ne sont pas présentes aux endroits que tu souhaite, essaie de rajouter une classe langue sur le body et ainsi tu pourra filtrer selon la langue.
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France


Retourner vers Developpement

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités

cron