bug du skin clean sous IE pc

Archive

Messagepar naga » Ven 03 Mar 2006, 18:24

Bonjour à tous,

Je me suis servis du template et des css du skin Clean pour faire le mien. Je découvre avec horreur que sur ma version il existe un décalage sur la page de chaque catégorie d'article. C'est un décalage des boxes de la sidebar de la hauteur du div des nouveaux produits pour le mois en cours. J'ai eu beau tous essayé je n'ai pas trouvé comment y remedier.

En essayant de tout reprendre à la base ( donc le skin Clean ) je découvre que le bug est aussi présent sur Clean ( testé IE pc et Firefox uniquement ). Ce décalage n'apparait que sur IE à ma connaissace.

Voici deux screenshot de ce phénomene:

http://www.image-dream.com/membre/up/nagaa/bug01.jpg ( skin clean )
http://www.image-dream.com/membre/up/nagaa/bug02.jpg ( skin perso )

Voila ma question est donc simple : avez vous déjà rencontré ce problème et y avait trouvé une solution ?

Merci d'avance
naga
Membre inactif
 
Messages: 6
Inscription: Lun 27 Fév 2006, 16:47

Messagepar utilisateur » Ven 03 Mar 2006, 19:44

il faut utiliser 2 à 3 navigateurs (ou plus) lors de la réalisation et personnalisation du layout CSS ...
et les actualiser lors de chaque modification importante, pour un peu voir où on en est
d'autant plus que IE présente de sérieuse lacunes au niveau de l'interprétation des CSS, je ne compte plus le nombre de hacks CSS que j'utilise pour justement faire ignorer à IE des informations incomprises.

au fait ton bug de IE, ça donne quoi sous Opéra ?
parce que là aussi on peut avoir quelques surprises des fois ;)
utilisateur
Membre actif
 
Messages: 19
Inscription: Mer 08 Fév 2006, 14:21

Messagepar naga » Ven 03 Mar 2006, 20:01

pour ce taff en particulier il ne m'étais pas demandé de testé la compatibilité sur tous les navigateurs mais seulement sur Firefox et IE, et d'ailleurs ca peut paraître débile mais je test très rarement mes sites pour des navigateurs qui représente une part de marché minuscule.

Les hack IE ici sont bien nombreux, il y a eu un jolie boulot d'effectué par le créateur du skin d'origine tu peux t'en rendre compte en regardant les differentes css.

Mais subsite toujours ce décalage qui rend le site innopérationnel et pour lequel je n'ai toujours pas trouvé de solution.

Je mets le point la dessus parcequ'il s'agit d'un bug qui est présent sur Clean, distribué si je ne me trompe pas dans le pack Oscss de base.
naga
Membre inactif
 
Messages: 6
Inscription: Lun 27 Fév 2006, 16:47

Messagepar utilisateur » Ven 03 Mar 2006, 20:34

naga a écrit:pour ce taff en particulier [...]

ouais mais bon ...
chez moi c'est une habitude, taf ou pas, demandé ou pas ;)
et puis Opera a beau représenter une part minuscule, il reste cependant un navigateur qui a une des meilleures restitutions des CSS ; ça peut donc aider à comprendre les soucis observés sur d'autres navigateurs (par recoupement).

et puis moi j'ai pas ou plus ce souci d'alignement sur mon layout basé sur un "clean" très modifié ;)
utilisateur
Membre actif
 
Messages: 19
Inscription: Mer 08 Fév 2006, 14:21

Messagepar domallia » Ven 03 Mar 2006, 20:57

Bonjour

J'ai eu le problème et je l'ai réglé en diminuant la largeur de la class #page content.
Il y a une différence d'interprétation pour IE qui nécessite un ajustement à la baisse de la largeur (fait l'essai avec une largeur beaucoup plus basse et tu verras!). La solution pour avoir quelque chose de correcte dans tous les navigateurs et de mettre deux largeurs différentes dans la classe #pagecontent :

width:520px;
width:510px !important;

Pour ce qui est de négliger les "navigateurs minoritaires", c'est une grosse erreur ! Les navigateurs en question représentent quand même 30% du marché environ et cela va en augmentant. A toi de savoir si tu veux perdre un potentiel de 30% de clients :o

A bientôt
Dernière édition par domallia le Ven 03 Mar 2006, 20:58, édité 1 fois.
domallia
Membre actif
 
Messages: 43
Inscription: Mer 19 Oct 2005, 22:51
Localisation: Savoie

Messagepar naga » Ven 03 Mar 2006, 20:58

J'ai eu le problème et je l'ai réglé en diminuant la largeur de la class #page content.
Il y a une différence d'interprétation pour IE qui nécessite un ajustement à la baisse de la largeur (fait l'essai avec une largeur beaucoup plus basse et tu verras!). La solution pour avoir quelque chose de correcte dans tous les navigateurs et de mettre deux largeurs différentes dans la classe #pagecontent :

width:520px;
width:510px !important;

Ah, super merci beaucoup !

30 % de marché ? ils sortent d'ou ces chiffres ? je pensais que c'était plutot du genre 10%firefox 85%Ie et 5%lesautres.


et puis Opera a beau représenter une part minuscule, il reste cependant un navigateur qui a une des meilleures restitutions des CSS ; ça peut donc aider à comprendre les soucis observés sur d'autres navigateurs (par recoupement).

quoi de plus que firefox ?
Dernière édition par naga le Ven 03 Mar 2006, 21:01, édité 1 fois.
naga
Membre inactif
 
Messages: 6
Inscription: Lun 27 Fév 2006, 16:47

Messagepar gremy » Ven 09 Juin 2006, 11:02

gremy
Membre actif
 
Messages: 14
Inscription: Jeu 08 Juin 2006, 14:46


Retourner vers osCSS 1.1

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités

cron