Envoie d'email quand commande passé

Archive

Messagepar jfdumais » Ven 16 Nov 2007, 18:57

Bon parfois quand une commande est passé sur la boutique, elle entre correctement dans la BD mais n'est pas envoyer par email.

Est-ce qu'il y aurait un problème connu à ce sujet ?
jfdumais
Membre inactif
 
Messages: 6
Inscription: Ven 16 Nov 2007, 18:39

Messagepar cymbeline » Ven 16 Nov 2007, 19:32

Bonjour,

Quelles précisions pourrais-tu nous apporter ? :)

En local, chez un hebergeur, dans l'admin -> configuration -> ma boutique et option mail quelles sont les valeurs renseignées.

Parfois veut dire que ce n'est pas tout le temps, donc est-ce qu'il y a des mails qui partent quand même ?

++
cymbeline
Membre très actif
 
Messages: 265
Inscription: Mer 06 Sep 2006, 20:01
Localisation: Nevers

Messagepar jfdumais » Ven 16 Nov 2007, 21:33

Le serveur est en linux Fedora Core 7 si je me souviens bien et est directement héberger à l'intérieur de l'entreprise.

J'ai plein accès au serveur alors s'il ya des choses a modifier ce n'est pas un problème.

Pour ce qui est des configurations, vous voulez savoir quoi exactement ?

Je ne connait pas tellement oscss car je n'ai jamais travailler avec celui ci pour le moment. Mais dans mon nouveau travail j'ai eu le mandat de savoir pourquoi ceci arrivait dans l'entreprise.

Merci de votre aide
jfdumais
Membre inactif
 
Messages: 6
Inscription: Ven 16 Nov 2007, 18:39

Messagepar jfdumais » Lun 19 Nov 2007, 18:33

Personne n'a jamais eu ce problème ?
jfdumais
Membre inactif
 
Messages: 6
Inscription: Ven 16 Nov 2007, 18:39

Messagepar jfdumais » Mar 27 Nov 2007, 19:20

Est-ce que vous pourriez me référer à d'autres forums ou personnes ?

Est-ce qu'une MAJ vers la version 1.2 pourrait être une option a envisagé ?
jfdumais
Membre inactif
 
Messages: 6
Inscription: Ven 16 Nov 2007, 18:39

Messagepar j4k » Mar 27 Nov 2007, 19:50

je pense plutot à un souci d'administration du serveur d'envoi qu'un souci oscss

il faudais que tu fasse des tests de la fonction mail() hors oscss pour voir si le problème d'envoi aléatoire est tjrs vérifié.

Cela peut venir de ton serveur d'envoi qui est bloqué (black listé) par certains provider ou l'inverse que ton serveur d'envoi bloque les mails vers certains providers. (par exemple tout les mail vers hotmail sont bloqués mais pas ceux vers mamadoo.fr, etc)

c'est un serveur dédié ou c'est chez un hébergeur ?
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar jfdumais » Mer 28 Nov 2007, 22:58

C'est un serveur dédié et le email dont je parle est le email qui s'envoit à l'interne de la compagnie pour dire qu'une nouvelle compagnie vient d'être passé sur le site.

Donc selon toi oscss n'a pas de problème connu à ce niveau alors le problème serait ailleurs ?
jfdumais
Membre inactif
 
Messages: 6
Inscription: Ven 16 Nov 2007, 18:39

Messagepar j4k » Jeu 29 Nov 2007, 00:42

non pas de souci de ce genre si la fonction mail() de php est activée.

as-tu fait des tests avec un script tout simple d'envoi d'email hors oscss?
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar jfdumais » Jeu 29 Nov 2007, 23:53

Oui et tout semble bien passer et la majorité du temps le email s'envoie convenablement mais la personne qui reçoit les emails en questions me mentionne que c'est déjà arriver qu'il ne recevait pas le email.

Le problème c'est que la personne se fit seulement aux emails et ne va jamais dans l'administration pour voir les commandes qui ont été passé.

Je vais avoir avec elle directement.

Je ne sais pas trop pourquoi des fois ce serait ok et d'autre fois non .... ya pas vraiment de raison à ça.
jfdumais
Membre inactif
 
Messages: 6
Inscription: Ven 16 Nov 2007, 18:39

Messagepar oscim » Mar 11 Mar 2008, 17:02

Pbs d'envoie de mail lors de comamnde passé.

Retour d'erreur sur oscss1.1RC1

il semble que les mail de copie de commande ne passe pas toujours.
Apres avoir verifié les config d'envoie de mail sur oscss, calé sur sendmail.
PS: Serveur mutualisé ovh.

J'ai mis a jour la class mail du front.
tel que
apres lgn 476:
<code php>
function send($to_name, $to_addr, $from_name, $from_addr, $subject = '', $headers = '') {
</code>

Ajouté

<code php>
## [modifie : 11.03.2008, 11:46:01] par a@oscim.fr Aurelien imhof
## pbs copie mail au webmstre boutique
## >>>>
if ((strstr($to_name, "n") != false) || (strstr($to_name, "r") != false)) {
return false;
}

if ((strstr($to_addr, "n") != false) || (strstr($to_addr, "r") != false)) {
return false;
}

if ((strstr($subject, "n") != false) || (strstr($subject, "r") != false)) {
return false;
}

if ((strstr($from_name, "n") != false) || (strstr($from_name, "r") != false)) {
return false;
}

if ((strstr($from_addr, "n") != false) || (strstr($from_addr, "r") != false)) {
return false;
}
## <<<<

</code>

De plus podifié serveur pr envoi sur smtp.
Pour un web au normes du W3C, pour un web plus propre !

- Download osCSS Toutes versions
- stable osCSS 2.1.0 (help|info|new dev) Official help|wiki|Tuto for osCSS 2 | doc doxygen
- Utiliser le tracker pour suivre les évolutions et développements
- Inscrivez vos sites sur oscss pour présenter vos réalisations
Avatar de l’utilisateur
oscim
Site Admin
 
Messages: 1643
Inscription: Mar 25 Sep 2007, 11:33


Retourner vers osCSS 1.1

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités

cron