[resolu] Installation online

Archive

Messagepar Fahaheel » Ven 28 Juil 2006, 03:36

Bonjour,

tout d'abord felicitations pour cette solution tres simple a modifier, c'est exactement ce que je cherchais.

J'ai donc presque fini de creer ma boutique en local. Or voulant faire des tests online, j'ai reinstalle oscss sur mon serveur et j'obtiens des erreurs.

Sur la page d'acceuil je peux lire :
Code: Tout sélectionner
Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid/gid is 1076/1000 is not allowed to access owned by uid/gid 0/0 in /home/*****/public_html/includes/functions/sessions.php on line 124

Warning: Cannot modify header information - headers already sent by (output started at /home/******/public_html/includes/functions/sessions.php:124) in /home/*****/public_html/includes/functions/general.php on line 1179

J'ai trouve une solution sur le forum oscommerce, il s'agit de renommer le dossier "/temp" par "temp" or je ne peux pas acceder a l'admin non plus, les erreurs suivants s'affichent :

Code: Tout sélectionner
Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid/gid is 1076/1000 is not allowed to access owned by uid/gid 0/0 in /home/*****/public_html/admin/includes/functions/sessions.php on line 116

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/*****/public_html/admin/includes/functions/sessions.php:116) in /home/*****/public_html/admin/includes/functions/sessions.php on line 73

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/*****/public_html/admin/includes/functions/sessions.php:116) in /home/*****/public_html/admin/includes/functions/sessions.php on line 73

Warning: Cannot modify header information - headers already sent by (output started at /home/*****/public_html/admin/includes/functions/sessions.php:116) in /home/*****/public_html/admin/includes/functions/general.php on line 93

:cool:
Fahaheel
Membre inactif
 
Messages: 2
Inscription: Jeu 29 Juin 2006, 12:32

Messagepar Fahaheel » Ven 28 Juil 2006, 15:23

Je viens de trouver la solution sur un forum.

Dans phpMyadmin il faut injecter la requete suivante.
Code: Tout sélectionner
UPDATE configuration SET configuration_value = 'tmp' WHERE configuration_key='SESSION_WRITE_DIRECTORY'

Ca marche chez moi. ;)
Fahaheel
Membre inactif
 
Messages: 2
Inscription: Jeu 29 Juin 2006, 12:32

Messagepar zmove » Mer 18 Oct 2006, 10:39

up, up et reup.

Je viens d'avoir le même pb en testant le site online...

merci pour ce post qui m'enlève une belle frayeur :)
OsCSS 1.1-RC1 + Mise à jour bug fix + mise à jour MC2 2.2 du 11/05/05
zmove
Membre actif
 
Messages: 30
Inscription: Ven 21 Juil 2006, 11:20

Messagepar azaroth » Lun 03 Sep 2007, 22:56

Bonsoir,

J'ai essayé mais quand je fais la manip, j'ai droit à ce message d'eereur de la part de ma base de donnée :

#1146 - La table 'resistanciaugor.configuration' n'existe pas

Vous l'aurez compris, ma basse s'appelle resistanciaugor. En dessous, l'arborescence comporte tous les éléments d'osCss

Pour faire comme indiqué ci-dessus, j'ai cliqué sur l'onglet SQL de ma BDD et après avoir collé la ligne ci-dessus, j'ai cliqué sur exécuter.

J'y comprends rien.

Je n'ai pas installé osCss en local, j'ai préféré l'installer en live, est-ce grave ? Je pense que non, mais sait-on jamais.

Une question : comment se fait-il que le problème survient malgré une installation classique avec le module prévu pour ? Est-il foireux ce module ou est-ce que ça vient de moi ?

Merci pour votre aide.
Dernière édition par azaroth le Mar 04 Sep 2007, 22:49, édité 1 fois.
azaroth
Membre actif
 
Messages: 47
Inscription: Lun 03 Sep 2007, 22:35

Messagepar azaroth » Jeu 06 Sep 2007, 01:13

J'ai posé la question à mon hébergeur et il a semble t-il déjà rencontré et solutionné ce problème, voici comment :

http://aide.sivit.fr/index.php?2007/04/11/177-os-commerce-probleme-avec-la-fonction-session_save_path

J'ai essayé, ça marche très bien, j'ai toujours quelques petites erreurs dans le panau d'admin mais ça ne gène en rien le fonctionnement de l'ensemble.
azaroth
Membre actif
 
Messages: 47
Inscription: Lun 03 Sep 2007, 22:35


Retourner vers osCSS 1.1

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités

cron