[Résolu] Erreur 404: not found

Archive

[Résolu] Erreur 404: not found

Messagepar jve » Lun 17 Jan 2011, 17:02

Bonjour à tous,
cela fait 3 semaines que je n'ai pas administrer ma boutique et donc pas fait de changement à proprement parler.
En voulant mettre à jour mes produits et insérer mon catalogue 2011 je me suis rendu compte d'un problème : Plus aucune catégories n'est accessibles via le frontend, je me retrouve avec une erreur 404 :

Not Found
The requested URL /jardin-douches-solaires-c-44_21.html was not found on this server.


je suppose qu'il s'agit d'un problème de réécriture URL mais je ne trouve pas d'ou vien le soucis.

Quelqu'un aurait eu le même soucis et pourrais m'aiguiller ?

Cordialement,
JVE
Dernière édition par jve le Lun 28 Fév 2011, 13:50, édité 3 fois.
jve
Membre actif
 
Messages: 54
Inscription: Lun 20 Sep 2010, 16:02

Re: Erreur 404: not found

Messagepar caracole » Lun 17 Jan 2011, 22:49

Bonjour. :)

Peux tu nous indiquer l'adresse de ton site?

Quelques questions Pour essayer de cerner le soucis :

Tu utilise bien la version 1.2?

As tu vérifier si les fichiers étaient présent sur ton FTP?

As tu vérifier si rien ne clochait au niveau de ta base de donnée?

Si tu as des précisions que tu pense susceptibles de nous aider à t'aider n'hésite pas. ;)
caracole
Contributeurs
 
Messages: 11
Inscription: Ven 14 Jan 2011, 14:08

Re: Erreur 404: not found

Messagepar jve » Mar 18 Jan 2011, 12:43

Edit
Dernière édition par jve le Mar 15 Fév 2011, 17:54, édité 1 fois.
jve
Membre actif
 
Messages: 54
Inscription: Lun 20 Sep 2010, 16:02

Re: Erreur 404: not found

Messagepar jve » Mar 18 Jan 2011, 13:45

Le .htaccess dont je vous ai founis le code est celui qui se trouve dans le dossier /include, visiblement aucun .htaccess n'est présent à la racine de ma boutique je suppose que le soucis viens de la, quelqu'un pourrait m'aide ?
jve
Membre actif
 
Messages: 54
Inscription: Lun 20 Sep 2010, 16:02

Re: Erreur 404: not found

Messagepar chever » Mar 18 Jan 2011, 17:30

Salut,

Normalement, tu devrais avoir .htaccess sur la racine.

En voici un de base mais qui est peut être a affiné avec les particularités de ton hebergeur.

Code: Tout sélectionner
# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
  <IfDefine SSL>
    SetEnvIf User-Agent ".*MSIE.*" \
             nokeepalive ssl-unclean-shutdown \
             downgrade-1.0 force-response-1.0
  </IfDefine>
</IfModule>

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

#<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
#  php_value register_globals 1
#</IfModule>


Options +FollowSymLinks
RewriteEngine On
RewriteCond %{REMOTE_ADDR} ^84.56.100.170$
RewriteRule ^.*$ - [F]


## uncomment if your site is on the root of your server or not ##
#RewriteBase /
RewriteBase /

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

# Redirection des liens brisés
ErrorDocument 404 /index.php

oscss 1.2/seo/point and rewards/featured et beaucoup de sueur
chever
Membre gold
 
Messages: 529
Inscription: Jeu 26 Juil 2007, 21:06
Localisation: Macon

Re: Erreur 404: not found

Messagepar cynic- » Mer 19 Jan 2011, 12:41

Je plussoie chever ^^

Un .htaccess à la racine, et un RewriteEngine On
cynic-
Site Admin
 
Messages: 694
Inscription: Mar 04 Déc 2007, 13:04

Re: Erreur 404: not found

Messagepar caracole » Mer 19 Jan 2011, 18:51

Je plussoie aussi, le .htaccess me parait une bonne piste. :)
caracole
Contributeurs
 
Messages: 11
Inscription: Ven 14 Jan 2011, 14:08

Re: Erreur 404: not found

Messagepar jve » Lun 14 Fév 2011, 22:42

Excuser moi de ne pas être revenu plus tôt. Et merci pour la solution ;)
jve
Membre actif
 
Messages: 54
Inscription: Lun 20 Sep 2010, 16:02

Re: Erreur 404: not found

Messagepar cynic- » Mar 15 Fév 2011, 18:41

De rien, précise [résolu] dans le titre du 1er post afin de ne pas attirer tous les modérateurs du coin :lol: ... et de préciser à d'autres utilisateurs que le souci, s'ils le rencontrent également, a été solutionné
cynic-
Site Admin
 
Messages: 694
Inscription: Mar 04 Déc 2007, 13:04


Retourner vers osCSS 1.2

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités

cron