Soucis avec les adresses

Archive

Messagepar AluCard » Mer 13 Mai 2009, 15:31

Voila j'explique mon problème,

J'ai installer OsCSS, jusque la pas de soucis mis a part le fichier configure.php de l'admin mais je me suis débrouillé.

Tout ce passait bien dans ma mise en place de la boutique qu'a un soucis de taille c'est posé a moi, la table "osc_address_format".

Au début, elle était inexistante, et après vérifications des .sql, il y a de rares insert into (5 pour être exact) mais aucune création de la table.
J'y suis donc aller au culot, j'ai pris la création de table des sql de la 1.2.1 j'ai créer, ca m'a éviter une belle erreur php qui plantait la boutique.

En revanche, ni dans les factures, ni dans les confirmations de payement naffiche les adresses. Elle sont pourtant bien disponible dans le carnet d'adresse donc bien ajoutées a la table "osc_address_book".

J'ai bien des requêtes dans general.php vers "osc_address_format" donc je dois dire que sur le coup je potage un peu.

Merci ^^


Ps : osCSS 1.2.1 me faisant une erreur 500 serveur, Le passage vers cette version ne peut pas être une solution pour moi, je suis forcer de faire avec la 1.2 donc a patcher ce soucis a la main
AluCard
Membre actif
 
Messages: 11
Inscription: Mer 13 Mai 2009, 15:19

Messagepar j4k » Mer 13 Mai 2009, 15:53

hello,

si tu reprends les requêtes que tu as identifiées et que tu le balance en sql dans phpmyadmin, est-ce que ça te remonte une erreur ou des résultats ?

concernant l'erreur 500 de ton serveur, ce serait aussi une idée de fouiner pour savoir d'ou ça vient et de le résoudre
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar AluCard » Mer 13 Mai 2009, 16:31

La requête aboutit avec succès, Je pense donc que c'est au niveaux de l'envoi qui ne doit pas exister ou pas fonctionner.
Je m'en remet donc entre vos mains plus expertes, je continue a chercher de mon coter sans grands espoirs si je trouve quelque chose je tiendrait au courant mais pour le moment votre aide est mon plus grand espoir ^^
AluCard
Membre actif
 
Messages: 11
Inscription: Mer 13 Mai 2009, 15:19

Messagepar j4k » Mer 13 Mai 2009, 18:14

l'envoi ?

mais si elle n'apparait pas dans les factures non plus .. de quel envoi peut il s'agir ?
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar AluCard » Mer 13 Mai 2009, 20:36

Je sais pas je fais juste une hypothèse sachant que la table est vide. Et que c'est elle qui a créer une erreur donc je supposais que ça pourrais venir de la pour peu que la table index bien comme je le pense les adresses.
Donc si quelqu'un a une solutions ou un piste a me donner pour faire un bricolage a la main pour les récupérées.

Merci
AluCard
Membre actif
 
Messages: 11
Inscription: Mer 13 Mai 2009, 15:19

Messagepar AluCard » Sam 16 Mai 2009, 03:39

Petit up ^^

Personne n'aurais une idée pour me sortir de cette boue ? ^^'
J'avoue vraiment caller
AluCard
Membre actif
 
Messages: 11
Inscription: Mer 13 Mai 2009, 15:19

Messagepar j4k » Sam 16 Mai 2009, 12:34

reprenons du départ.

lorsque tu cré un nouveau compte utilisateur, les adresse sont bien enregistrée, les données présentes dans la base par conter elle n'apparaissent pas dans le mail de confirmation de commande ni dans la facture.

Ai-je bien décris ton problème ?
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar AluCard » Sam 16 Mai 2009, 15:12

Voila c'est bien ça dans les grandes lignes.
AluCard
Membre actif
 
Messages: 11
Inscription: Mer 13 Mai 2009, 15:19

Messagepar j4k » Mer 20 Mai 2009, 13:30

Pour résoudre le problème il fallait bien recréer la table mais aussi lui intégré son contenu.

voici la requête complète nécessaire à la création et à l'injection des données :

Code: Tout sélectionner
DROP TABLE IF EXISTS osc_address_format;
CREATE TABLE osc_address_format (
  address_format_id int(11) NOT NULL auto_increment,
  address_format varchar(128) NOT NULL default '',
  address_summary varchar(48) NOT NULL default '',
  PRIMARY KEY  (address_format_id)
);

insert into osc_address_format (address_format_id, address_format, address_summary) values ('1', '$firstname $lastname$cr$streets$cr$city, $postcode$cr$statecomma$country', '$city / $country');
insert into osc_address_format (address_format_id, address_format, address_summary) values ('2', '$firstname $lastname$cr$streets$cr$city, $state    $postcode$cr$country', '$city, $state / $country');
insert into osc_address_format (address_format_id, address_format, address_summary) values ('3', '$firstname $lastname$cr$streets$cr$city$cr$postcode - $statecomma$country', '$state / $country');
insert into osc_address_format (address_format_id, address_format, address_summary) values ('4', '$firstname $lastname$cr$streets$cr$city ($postcode)$cr$country', '$postcode / $country');
insert into osc_address_format (address_format_id, address_format, address_summary) values ('5', '$firstname $lastname$cr$streets$cr$postcode $city$cr$country', '$city / $country');

(il semble en effet que la creation de cette table ai disparu du fichier d'install)
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar AluCard » Dim 24 Mai 2009, 04:22

C'était bien ça je te remercie ^^
AluCard
Membre actif
 
Messages: 11
Inscription: Mer 13 Mai 2009, 15:19


Retourner vers osCSS 1.2

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

cron