Déboires avec IIS (boucles de redirection pour commencer)

Archive

Messagepar gloper » Jeu 16 Juil 2009, 23:05

Bonjour à tous,


Après des heures de combat acharné et de recherches pour résoudre mon problème, je me tourne vers vous, défait.


J'ai installé oscss sur un IIS avec extension php, et à force de bidouilles j'ai réussi à tout faire fonctionner sauf l'url rewriting qui m'envoyait dans les choux à tour de bras. N'ayant pas la foi d'essayer de voir ce qui fonctionnerait avec IIS, j'ai tout simplement mis à false l'attribut ENABLED quelque part dans le fichier de classe seo (car dans configuration => seo urls rien n'était affiché)

Je me retrouve donc avec des urls telles que
http://xxx.xxx.xxx.xxx/boutique/index.php?cPath=6

Et j'ai le droit en résultat à

"Boucle de redirection
Firefox a détecté que le serveur redirige la demande pour cette adresse d'une manière qui n'aboutira pas."

Plutôt qu'à la jolie 404 qui se présentait à moi lorsque seo était activé (sans toutefois fonctionner)


Voilà, je pense avoir tout dit, j'espère que vous pourrez m'aider et vous remercie par avance.
Dernière édition par gloper le Ven 17 Juil 2009, 14:59, édité 1 fois.
gloper
Membre inactif
 
Messages: 4
Inscription: Jeu 16 Juil 2009, 22:58

Messagepar j4k » Jeu 16 Juil 2009, 23:47

Salut et bienvenue sur le forum,

ce problème de boucle de redirection a deja été rencontré sur d'autres config (easyphp). Tu peux voir ce qui a déjà été dis la dessus :
http://forums.oscss.org/viewtopic.php?pid=6519#p6519

Fais nous savoir les retour que tu auras sur IIS
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar gloper » Ven 17 Juil 2009, 12:21

Bonjour et merci pour ta réponse,

J'ai déjà compulsé une bonne partie des sujets du forum, incluant celui dont tu me donnes le lien, mais je n'ai pas réussi à régler le problème, c'est bien pourquoi je me suis décidé à poster.

IIS ne gère pas les .htaccess, et j'avais pensé qu'en désactivant simplement SEO c'eût fonctionné, mais ce n'est pas le cas, j'ai dû rater quelque chose..

Mon php.ini contient

register_long_arrays On
et register_globals que je viens de mettre sur On pour tester, en vain


L'interface d'administration m'est accessible, et les pages qui ne semblent pas se baser directement sur la catalogue fonctionnent, comme :

http://xxx.xxx.xxx.xxx/boutique/index.php?language=en


Mais celles détaillant les catégories ou encore les produits m'affichent l'erreur.


Où puis-je configurer manuellement (en dur dans les fichiers) la désactivation de SEO ?
A part mettre le ENABLED à false dans son fichier de classe php, je n'ai fait aucune autre manip ce concernant, peut-être dois-je paramétrer ailleurs également..


Dites-moi si vous avez besoin de plus amples détails, car j'avoue patauger >_<
gloper
Membre inactif
 
Messages: 4
Inscription: Jeu 16 Juil 2009, 22:58

Messagepar gloper » Ven 17 Juil 2009, 12:55

Ah !

Je pense que je viens de résoudre mon problème !
Comme je vous l'avais dit, pour une raison mystérieuse, rien ne s'affichait dans le menu pour SEO URLs dans l'interface d'admin, donc moi, bête et méchant, je suis allé mettre

default_config['SEO_ENABLED']

à false dans seo.class.php, pensant que ça suffirait pour désactiver directement SEO.

J'avais tort, il faut mettre toutes les valeurs à FALSE (ou tout désactiver si SEO apparaît dans votre menu de config), et ça fonctionne !


Bon, j'espère que mes déboires pourront toujours servir à d'autres.


Je vous tiendrai au courant de mes avancées notables sur mon IIS si un retour sur cette plateforme vous intéresse ;)
gloper
Membre inactif
 
Messages: 4
Inscription: Jeu 16 Juil 2009, 22:58

Messagepar oscim » Ven 17 Juil 2009, 13:00

Bonjour,

Je vous tiendrai au courant de mes avancées notables sur mon IIS si un retour sur cette plateforme vous intéresse wink

Bien sur que les retour nous interresse
Pour un web au normes du W3C, pour un web plus propre !

- Download osCSS Toutes versions
- stable osCSS 2.1.0 (help|info|new dev) Official help|wiki|Tuto for osCSS 2 | doc doxygen
- Utiliser le tracker pour suivre les évolutions et développements
- Inscrivez vos sites sur oscss pour présenter vos réalisations
Avatar de l’utilisateur
oscim
Site Admin
 
Messages: 1643
Inscription: Mar 25 Sep 2007, 11:33

Messagepar j4k » Ven 17 Juil 2009, 13:13

je trouve ça bizarre. si SEO est désactivé dans l'admin il n'y a rien à modifier dans les fichiers pour le rendre inactif.

je pense plutot au Cache osCSS qui n'était pas vide et qui avais conservé les liens vers des pages nécessitant le htaccess -- ce serait bien de vérifier (allez va-zy remet ton site en vrac pour nous dire ;)
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar gloper » Ven 17 Juil 2009, 13:42

Voilà à quoi ressemble le menu SEO depuis le premier jour, je n'ai donc jamais pu y faire la moindre manip, d'où mes bidouilles en dur :

http://img174.imageshack.us/img174/2762/mouai.png


[remise du site en vrac]

**** processing ****

[site en vrac]

**** success ****



Bon, il semblerait que ce ne soit pas un ennui au niveau du cache :

seo_cache vide dans la bdd avant la manip, pareil pour le répertoire de cache

manip : remise des attributs à true dans seo.class.php sauf ENABLED qui reste à false

résultat : l'erreur se reproduit en chargeant une page.

impact au niveau du dossier de cache : aucun

impact au niveau de la table seo_cache : 3 nouvelles occurrences


Je remets tout à false, plus d'erreurs.
gloper
Membre inactif
 
Messages: 4
Inscription: Jeu 16 Juil 2009, 22:58


Retourner vers osCSS 1.2.1

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

cron