Probleme après installation de oscss 1.2.1 : le site ne se charge pas

Archive

Messagepar pedrope » Dim 05 Oct 2008, 18:11

Bonjour,
J'ai téléchargé oscss version 1.2.1 .
Quand je charge le site par défaut, rien ne s'affiche dans la colonne de gauche si ce n'est en haut un message d'erreur "unable to determine the link page" .
Je n'ai pas non plus le footer .
J'utilise Wamp Server version 2.0 et php5 .
J'ai cherché sur le forum et lu beaucoup de posts mais je n'ai pas trouvé de réponses à mon problème .
Merci de votre aide
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar chever » Dim 05 Oct 2008, 21:30

PEDROPE,

jette un coup d'oeil sur ce post
Pb avec version 121 finalhttp://forums.oscss.org/viewtopic.php?id=1171&p=2

Il doit aussi s'agir d'un problème avec GD
Dernière édition par chever le Dim 05 Oct 2008, 21:31, édité 1 fois.
oscss 1.2/seo/point and rewards/featured et beaucoup de sueur
chever
Membre gold
 
Messages: 529
Inscription: Jeu 26 Juil 2007, 21:06
Localisation: Macon

Messagepar pedrope » Lun 06 Oct 2008, 16:44

Bonjour,

J'avais trouvé ce post et j'avais essayé la manip suivante:
dans WAMP, je suis allé dans les extensions PhP et j'ai décoché php_gd2.
Est-ce la bonne manip pour désactiver GD ?
Merci
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar j4k » Lun 06 Oct 2008, 17:22

il faut que gd soit activé pas désactivé !
si il ne l'ai pas lis le post que chever t'a donné il y a un patch pour fixer le problème
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar pedrope » Lun 06 Oct 2008, 18:06

J'ai donc re-coché gd_2 et j'ai appliqué la modif suggérée dans le post pré-cité.

Voici la copie de mon html_output.php: avec ton code
Code: Tout sélectionner
 ////
// The HTML image wrapper function
  function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '') {

    if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) {
      return false;
    }
// automatic thumbails
//Mise en commentaire du source original
  /*if ($image_size = @getimagesize($src)) {
  if ((CONFIG_CALCULATE_IMAGE_SIZE == 'true' && $src != DIR_WS_IMAGES . 'pixel_black.gif' && $src != DIR_WS_IMAGES . 'pixel_trans.gif' && $src != DIR_WS_IMAGES . 'pixel_silver.gif' )) {
     if ( ($width) || ($height) ) {
        if ( $width=="100%" ) {
       $width = $image_size[0];
        } elseif ( $height=="100%" ) {
        $height = $image_size[1];
       } elseif ( $width==0 ) {
        unset($width);
        } elseif ( $height==0 ) {
       unset($height);
       }
       $src=thumbimage(DIR_FS_CATALOG . '/' .$src, $width, $height, 1, 1, DIR_FS_CATALOG . '/' . DIR_WS_IMAGES . 'imagecache');
        if ((($image_size[1]/$height) > ($image_size[0]/$width) ) && $height>0){
          $width=ceil(($image_size[0]/$image_size[1])* $height);
        } elseif ($width>0) {
         $height=ceil($width/($image_size[0]/$image_size[1]));
       }
     }
   }
 } else {   
  } if ($image_size = @getimagesize($src)) {
        if (empty($width) && tep_not_null($height)) {
          $ratio = $height / $image_size[1];
          $width = $image_size[0] * $ratio;
        } elseif (tep_not_null($width) && empty($height)) {
          $ratio = $width / $image_size[0];
          $height = $image_size[1] * $ratio;
        } elseif (empty($width) && empty($height)) {
          $width = $image_size[0];
          $height = $image_size[1];
        }
      } elseif (IMAGE_REQUIRED == 'false') {
        return false;
      }*/
    // correctif remplacant ci dessus
   
    if (function_exists("gd_info")) {
    if ((CONFIG_CALCULATE_IMAGE_SIZE == 'true' && $src != DIR_WS_IMAGES . 'pixel_black.gif' && $src != DIR_WS_IMAGES . 'pixel_trans.gif' && $src != DIR_WS_IMAGES . 'pixel_silver.gif' )) {
            if ( ($width) || ($height) ) {
                if ( $width=="100%" ) {
                $width = $image_size[0];
                } elseif ( $height=="100%" ) {
                $height = $image_size[1];
                } elseif ( $width==0 ) {
                unset($width);
                } elseif ( $height==0 ) {
                unset($height);
                }
                $src=thumbimage(DIR_FS_CATALOG . '/' .$src, $width, $height, 1, 1, DIR_FS_CATALOG . '/' . DIR_WS_IMAGES . 'imagecache');
                if ((($image_size[1]/$height) > ($image_size[0]/$width) ) && $height>0){
                    $width=ceil(($image_size[0]/$image_size[1])* $height);
                } elseif ($width>0) {
                    $height=ceil($width/($image_size[0]/$image_size[1]));
                }
            }
        }
    } else {       
    } if ($image_size = @getimagesize($src)) {
        if (empty($width) && tep_not_null($height)) {
          $ratio = $height / $image_size[1];
          $width = $image_size[0] * $ratio;
        } elseif (tep_not_null($width) && empty($height)) {
          $ratio = $width / $image_size[0];
          $height = $image_size[1] * $ratio;
        } elseif (empty($width) && empty($height)) {
          $width = $image_size[0];
          $height = $image_size[1];
        }
      } elseif (IMAGE_REQUIRED == 'false') {
        return false;
      }

le problème reste le même.

J'ai ensuite essayé le code de CHEVER :
Code: Tout sélectionner
// The HTML image wrapper function
  function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '') {

    if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) {
      return false;
    }
// automatic thumbails
//Mise en commentaire du source original
 /*if ($image_size = @getimagesize($src)) {
  if ((CONFIG_CALCULATE_IMAGE_SIZE == 'true' && $src != DIR_WS_IMAGES . 'pixel_black.gif' && $src != DIR_WS_IMAGES . 'pixel_trans.gif' && $src != DIR_WS_IMAGES . 'pixel_silver.gif' )) {
     if ( ($width) || ($height) ) {
        if ( $width=="100%" ) {
       $width = $image_size[0];
        } elseif ( $height=="100%" ) {
        $height = $image_size[1];
       } elseif ( $width==0 ) {
        unset($width);
        } elseif ( $height==0 ) {
       unset($height);
       }
       $src=thumbimage(DIR_FS_CATALOG . '/' .$src, $width, $height, 1, 1, DIR_FS_CATALOG . '/' . DIR_WS_IMAGES . 'imagecache');
        if ((($image_size[1]/$height) > ($image_size[0]/$width) ) && $height>0){
          $width=ceil(($image_size[0]/$image_size[1])* $height);
        } elseif ($width>0) {
         $height=ceil($width/($image_size[0]/$image_size[1]));
       }
     }
   }
 } else {   
  } if ($image_size = @getimagesize($src)) {
        if (empty($width) && tep_not_null($height)) {
          $ratio = $height / $image_size[1];
          $width = $image_size[0] * $ratio;
        } elseif (tep_not_null($width) && empty($height)) {
          $ratio = $width / $image_size[0];
          $height = $image_size[1] * $ratio;
        } elseif (empty($width) && empty($height)) {
          $width = $image_size[0];
          $height = $image_size[1];
        }
      } elseif (IMAGE_REQUIRED == 'false') {
        return false;
      }*/
    // correctif remplacant ci dessus
   
if ($image_size = @getimagesize($src)) {
    if ((CONFIG_CALCULATE_IMAGE_SIZE == 'true' && $src != DIR_WS_IMAGES . 'pixel_black.gif' && $src != DIR_WS_IMAGES . 'pixel_trans.gif' && $src != DIR_WS_IMAGES . 'pixel_silver.gif' )) {
            if ( ($width) || ($height) ) {
                if ( $width=="100%" ) {
                $width = $image_size[0];
                } elseif ( $height=="100%" ) {
                $height = $image_size[1];
                } elseif ( $width==0 ) {
                unset($width);
                } elseif ( $height==0 ) {
                unset($height);
                }
                $src=thumbimage(DIR_FS_CATALOG . '/' .$src, $width, $height, 1, 1, DIR_FS_CATALOG . '/' . DIR_WS_IMAGES . 'imagecache');
                if ((($image_size[1]/$height) > ($image_size[0]/$width) ) && $height>0){
                    $width=ceil(($image_size[0]/$image_size[1])* $height);
                } elseif ($width>0) {
                    $height=ceil($width/($image_size[0]/$image_size[1]));
                }
            }
        }
    } else {       
    } if ($image_size = @getimagesize($src)) {
        if (empty($width) && tep_not_null($height)) {
          $ratio = $height / $image_size[1];
          $width = $image_size[0] * $ratio;
        } elseif (tep_not_null($width) && empty($height)) {
          $ratio = $width / $image_size[0];
          $height = $image_size[1] * $ratio;
        } elseif (empty($width) && empty($height)) {
          $width = $image_size[0];
          $height = $image_size[1];
        }
      } elseif (IMAGE_REQUIRED == 'false') {
        return false;
      }

Le problème n'est pas plus résolu...
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar j4k » Lun 06 Oct 2008, 18:46

est-il possible de voir la page en ligne ?

sinon peux-tu faire une copie d'écran ?

le footer s'affiche ?
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar pedrope » Lun 06 Oct 2008, 18:57

Question bête : comment fait on une copie d'écran ?
le footer ne s'affiche pas
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar pedrope » Lun 06 Oct 2008, 19:11

J'ai capturé une image du site comment puis-je te l'envoyer ?
Faut-il absolument passer par un hébergeur d'images ?
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar chever » Lun 06 Oct 2008, 19:13

Pour l'impression ecran tu dois trouver la touche Impécr, ouvrir un éditeur d'image et faire coller

Quel template, utilise-tu ?
oscss 1.2/seo/point and rewards/featured et beaucoup de sueur
chever
Membre gold
 
Messages: 529
Inscription: Jeu 26 Juil 2007, 21:06
Localisation: Macon

Messagepar pedrope » Lun 06 Oct 2008, 19:17

J'utilise le template par défaut, celui qui est utilisé dans le pack d'installation.
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar chever » Lun 06 Oct 2008, 19:48

arf, je me rappelle plus duquel il s'agit.
Si c'est celui à dominance bleu organise en 3 colonnes, il s'agit de generic.
Si ma mémoire est bonne, j'avais été obligé de mettre dans template.php

Code: Tout sélectionner
<!--[if !IE]> <--> <div id="pageContent">   <!--> <![endif]-->
  <!--[if IE]> <div id="pageContent_IE">  <![endif]-->
   <?php require_once(DIR_WS_INCLUDES.'content/'. $page_content); ?></div>

 </div><!-- end #page -->

entre les deux div corresponant aux colonnes et non à la fin comme c'est le cas dans le fichier d'origine.

Faut pas me demander pourquoi, mais ca m'avait résolu pas mal de probleme d'affichage
oscss 1.2/seo/point and rewards/featured et beaucoup de sueur
chever
Membre gold
 
Messages: 529
Inscription: Jeu 26 Juil 2007, 21:06
Localisation: Macon

Messagepar pedrope » Lun 06 Oct 2008, 20:19

J'ai cherché mais c'est un peu compliqué car je ne peux pas rentrer dans l'admin .
Le template utilisé pour le site par défaut est le template oscss avec plutôt des tons verts sur le bandeau .
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar pedrope » Lun 06 Oct 2008, 20:28

pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar j4k » Lun 06 Oct 2008, 22:16

les vignettes des produits s'affichent ?

avec un autre template, le phénomène se reproduit ?
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar pedrope » Lun 06 Oct 2008, 23:49

Avec le template clean , c'est la même chose : j'ai toujours "langue , error (écrit en rouge) et unable to determine the page link .
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar j4k » Mar 07 Oct 2008, 00:07

as-tu essayer de décocher le redimensionnement auto des images dans l'admin ?
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France

Messagepar pedrope » Mar 07 Oct 2008, 00:35

Je n'ai pas acces à l'admin à cause d'un pb de redirection infinie (celui ci fait l'objet d'un autre post) .
Pour changer le template, je suis allé directement faire un update de la base de données avec une requête sql .
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar pedrope » Jeu 09 Oct 2008, 01:30

Bonsoir,
Le problème est résolu .
J'utilise Wamp Server version 2.0 php 5.2.6 .
J'ai téléchargé le kit oscss 1.2.1 .

Pour entrer dans l'admin et charger le site par défaut, il faut mettre dans Configuration php
php_flag register_long_arrays sur ON
php_value register_globals sur ON
php_flag display_errors sur Off .

Merci à tous pour votre aide et BZMUZ pour sa solution .
pedrope
Membre actif
 
Messages: 33
Inscription: Dim 05 Oct 2008, 17:40

Messagepar bzmuz » Jeu 09 Oct 2008, 16:53

dans Configuration php?

tu peux préciser ou corriger pour que ça serve à d'autres?
bzmuz
Membre actif
 
Messages: 20
Inscription: Mar 07 Oct 2008, 18:16

Messagepar j4k » Jeu 09 Oct 2008, 16:56

je pense qu'il voulait dire php.ini
~ osCSS 1.2.1 ~
Avatar de l’utilisateur
j4k
Site Admin
 
Messages: 1259
Inscription: Mer 27 Avr 2005, 09:13
Localisation: France


Retourner vers osCSS 1.2.1

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités

cron