[Résolu]Connexion impossible à l'admin

Nouvelle génération du moteur osCSS
téléchargement osCSS 2.x.x

[Résolu]Connexion impossible à l'admin

Messagepar Brain » Dim 24 Avr 2011, 15:59

Bonjour,
Je viens d'installer plusieurs fois oscss version 2.1.0 sur un serveur dédié NFrance en php5 manuellement et en netinstall.
Les installations se passent correctement à chaque fois, je peux accéder à la partie public de la boutique mais pas à l'admin.
Je rentre mon login et mot de passe et il revient sans aucun message d'erreur sur login.php
Je n'ai un message d'erreur que si je rentre un login ou mot de passe erroné.
Je viens de constater également que dans la partie public de la boutique les articles (appareils photos de l'exemple) ne s'ajoutent pas au panier. Est-ce lié?
J'ai les cookies bien activés et j'ai ce problème depuis n'importe quel pc.
Quelqu'un aurait-il une idée? Merci d'avance
Dernière édition par Brain le Ven 13 Mai 2011, 17:49, édité 1 fois.
Brain
Membre actif
 
Messages: 69
Inscription: Dim 24 Avr 2011, 15:50

Re: Connexion impossible à l'admin

Messagepar chever » Dim 24 Avr 2011, 20:34

Je pense qu'il s'agit d'un probleme d'identification
Pour l'adresse email, il s'agit de celle que tu as rentre pdt l'install.
Le mot de passe est admin.

As tu essaye de régénéré un nouveau mot de passe avec mot de passe oublié
oscss 1.2/seo/point and rewards/featured et beaucoup de sueur
chever
Membre gold
 
Messages: 529
Inscription: Jeu 26 Juil 2007, 21:06
Localisation: Macon

Re: Connexion impossible à l'admin

Messagepar Brain » Dim 24 Avr 2011, 23:59

Tout d'abord merci pour la réponse.
L'adresse email et le mot de passe sont corrects, le problème ne vient pas de là.
Car quand je rentre une adresse mail ou un mot de passe erroné là j'ai bien un message d'erreur écrit en rouge indiquant qu'il y a une erreur.
Mais lorsque l'adresse mail et le mot de passe sont corrects il revient systématiquement sur la page login.php sans aucun message d'erreur.
Brain
Membre actif
 
Messages: 69
Inscription: Dim 24 Avr 2011, 15:50

Re: Connexion impossible à l'admin

Messagepar Brain » Lun 25 Avr 2011, 00:02

Je viens d'avoir un message d'erreur, c'est étrange je n'en avais jamais eu avant....?
Fatal error: Class 'Database' not found in /home/html/store/admin/includes/functions/sessions.php on line 39

J'ai donc modifié configure.php pour ne plus gérer les sessions par mysql mais par fichier et là je peux me connecter à l'admin.
Quelqu'un a-t-il déjà eu ce problème?
Brain
Membre actif
 
Messages: 69
Inscription: Dim 24 Avr 2011, 15:50

Re: Connexion impossible à l'admin

Messagepar Ayatus » Mar 26 Avr 2011, 12:08

Salut,

Je n'ai jamais rencontré une telle erreur d'autant que la classe Database est bien présente dans catalog/common/classes/Database.php.
Sans cette classe, il est impossible de faire fonctionner oscss2 puisqu'elle gère l'ensemble des requêtes à la DB.
Avatar de l’utilisateur
Ayatus
Site Admin
 
Messages: 280
Inscription: Sam 19 Avr 2008, 17:23


Retourner vers Bug / Aides [fr]

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

cron