Probleme pour installer une extention

Suivi , trace , bugs, info , news sur les extensions, les plugins, les modules associé au moteur.

Probleme pour installer une extention

Messagepar cabrio2b » Jeu 23 Déc 2010, 18:41

Bonjour,

J'ai un souci sur mon serveur de production lorsque j'essaie d'installer l'extention special (promotion) voici l'erreur :

Code: Tout sélectionner
Fatal error: Tc_addfile error do_install in xxx/admin/includes/exts/package/tags/addfile.php on line 231


Je viens de passer deux heures dessus et je n'arrive pas a comprendre .

Merci
cabrio2b
Membre actif
 
Messages: 29
Inscription: Dim 09 Nov 2008, 20:09

Re: Probleme pour installer une extention

Messagepar oscim » Jeu 23 Déc 2010, 18:44

Tu peut me montrer la totalité du retour de l'installation .

La tel que j'en vois pas assez, mais ne montre pas les chemin complet de ton serveur
Pour un web au normes du W3C, pour un web plus propre !

- Download osCSS Toutes versions
- stable osCSS 2.1.0 (help|info|new dev) Official help|wiki|Tuto for osCSS 2 | doc doxygen
- Utiliser le tracker pour suivre les évolutions et développements
- Inscrivez vos sites sur oscss pour présenter vos réalisations
Avatar de l’utilisateur
oscim
Site Admin
 
Messages: 1643
Inscription: Mar 25 Sep 2007, 11:33

Re: Probleme pour installer une extention

Messagepar cabrio2b » Jeu 23 Déc 2010, 18:46

Heu c'est l'intégralité du retour de l'install du plugin ...
cabrio2b
Membre actif
 
Messages: 29
Inscription: Dim 09 Nov 2008, 20:09

Re: Probleme pour installer une extention

Messagepar oscim » Jeu 23 Déc 2010, 18:53

Ok, tu a installé la boutique via la net install ? ou à la mano ?

si tu les as installé a la mano, verifie que l'installateur peut ecrire, dans les repertoire et sous repertoire modules/ et languages/ coté admin et public.

D'autre part, pour supprimer l'erreur fatal , tu peut soit commenter la ligne 231 du fichier mentionné dans l'erreur, soit activé le collecteur d'erreur qui doit être desactiver par defaut. (modif recente, je ne suis plus sur)

Pour modifier le collecteur d'erreur, il s'agit de la valeur de la constante OSCSS_GARBAGE_ERROR dans le fichier configure de l'admin
Pour un web au normes du W3C, pour un web plus propre !

- Download osCSS Toutes versions
- stable osCSS 2.1.0 (help|info|new dev) Official help|wiki|Tuto for osCSS 2 | doc doxygen
- Utiliser le tracker pour suivre les évolutions et développements
- Inscrivez vos sites sur oscss pour présenter vos réalisations
Avatar de l’utilisateur
oscim
Site Admin
 
Messages: 1643
Inscription: Mar 25 Sep 2007, 11:33

Re: Probleme pour installer une extention

Messagepar cabrio2b » Jeu 23 Déc 2010, 19:04

L'install est faite a la mano ;)
J'ai bien les droit sur les dossiers.
J'ai activer la constante OSCSS_GARBAGE_ERROR voici le retour :

Code: Tout sélectionner
    * INFO :nodeName contrib (nodeType 1) = nodeValue www.oscim.fr oscim 2.0 define('BOX_CATALOG_SPECIALS', 'Promotion'); define('BOX_CATALOG_SPECIALS', 'Special'); $tabl_link[]= array(FILENAME_SPECIALS, 'BOX_CATALOG_SPECIALS', 'specials', @$img['specials']); CG_OPTION_MODULES MODULE_ACA_SPECIALS_SORT_ORDER Sort order of process. true Sort order of process. 1
    * INFO :nodeName description (nodeType 1) = nodeValue www.oscim.fr oscim 2.0
    * INFO :nodeName addfile (nodeType 1) = nodeValue
    * INFO :nodeName addfilelg (nodeType 1) = nodeValue
    * INFO :nodeName add2endlg (nodeType 1) = nodeValue define('BOX_CATALOG_SPECIALS', 'Promotion'); define('BOX_CATALOG_SPECIALS', 'Special');
    * INFO :nodeName add2end (nodeType 1) = nodeValue $tabl_link[]= array(FILENAME_SPECIALS, 'BOX_CATALOG_SPECIALS', 'specials', @$img['specials']);
    * INFO :nodeName config (nodeType 1) = nodeValue CG_OPTION_MODULES MODULE_ACA_SPECIALS_SORT_ORDER Sort order of process. true Sort order of process. 1
    * INFO :Run time : les fichiers sont identique ok! sortie pour /xxx/admin/includes/modules/pages/specials.php
    * INFO :Run time : les fichiers sont identique ok! sortie pour /xxx/admin/includes/modules/products/specials.php
    * INFO :Run time : les fichiers sont identique ok! sortie pour /xxx/admin/includes/gabarit/specials.listing.gab
    * INFO :Run time : les fichiers sont identique ok! sortie pour /xxx/admin/includes/gabarit/specials.edit.gab
    * INFO :Run time : les fichiers sont identique ok! sortie pour /xxx/admin/includes/gabarit/specials.delete.gab
    * [[0.03835106]]FATAL :Tc_addfile->do_install::230:: SPECIALS_stable Run time error: Couldn't copy file:
      original:: /xxx/admin/contributions/SPECIALS_stable/catalog/admin/includes/gabarit/products.specials.d.gab
      copy:: /xxx/admin/includes/gabarit/products.specials.d.gab
    * [[0.03881788]]FATAL :tag_xml-[1]addfile->do_install():: SPECIALS_stable Erreur durant traitement de cette fonction
    * INFO :delete folder ,okSPECIALS_stable
    * INFO :Install update db table_cip


Merci
cabrio2b
Membre actif
 
Messages: 29
Inscription: Dim 09 Nov 2008, 20:09

Re: Probleme pour installer une extention

Messagepar oscim » Jeu 23 Déc 2010, 19:13

Ok, l'erreur est la:

Code: Tout sélectionner
[[0.03835106]]FATAL :Tc_addfile->do_install::230:: SPECIALS_stable Run time error: Couldn't copy file:
      original:: /xxx/admin/contributions/SPECIALS_stable/catalog/admin/includes/gabarit/products.specials.d.gab


En fait, il ne trouve pas le fichier products.specials.d.gab, qui n'existe pas.

J'ai fait une coquille dans le fichier d'install, il faut remplacer en lg 19 du fichier install.xml dans ton dossier admin/contributions/SPECIALS_stable/

par

Code: Tout sélectionner
    <file name="admin/includes/gabarit/products.specials.display_inline.gab" />


Je vais refaire un zip , mais ca devrait te débloquer

PS, j'ai mis a jour le paquet :D :D
Pour un web au normes du W3C, pour un web plus propre !

- Download osCSS Toutes versions
- stable osCSS 2.1.0 (help|info|new dev) Official help|wiki|Tuto for osCSS 2 | doc doxygen
- Utiliser le tracker pour suivre les évolutions et développements
- Inscrivez vos sites sur oscss pour présenter vos réalisations
Avatar de l’utilisateur
oscim
Site Admin
 
Messages: 1643
Inscription: Mar 25 Sep 2007, 11:33

Re: Probleme pour installer une extention

Messagepar cabrio2b » Jeu 23 Déc 2010, 19:23

Merci pour ce point la mais après Noël je reviendrai vers vous pour vous faire un retour complet sur les erreurs que je rencontre avec votre extension

Joyeux Noël a vous ;)
cabrio2b
Membre actif
 
Messages: 29
Inscription: Dim 09 Nov 2008, 20:09


Retourner vers Extensions [fr]

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

cron